Internet ExplorerIE6 has been outdated and not much supported, however still its in use a lot of places. One of common issues that we see is annoying warning "This page contains both secure and non secure items. Do you want to display the non secure items?" that is displayed while browsing the website using IE6. This is not the case with using the latest version of IE 7/8 or Firefox. This normally when a web page is served over https and some of the assets like image, css, javascript etc. are loaded from a non ssl protocol i.e. over http. This is just a warning that the end user would get, this is not a good customer experience as it raises concerns about the security/privacy offered by website. <!>

Heare is the screen shot of the error that would be displayed.

Non Secure IE WarningIn order to resolve this the developer needs to review each and every artifact that is loaded for that webpage. Here again Firefox with the Firebug plugin can come to the rescue. Using Firebug one can see all the artifacts that are loaded and anything that is loaded with https can be found. Subsequently all these url need to be changed to use https, that would resolve the issue.

However the client browser can also change a flag in thier IE security setting to disable this warning if that option is applicable. Here are the steps.


1) Launch Internet Explorer.
2) Click on the Tools Menu.
3) Go to on Internet Options.
4) Go to the Security Tab.
5) Click on the Custom Level button.
6) Under the Miscellaneous section look for the setting "Display Mixed Content".
7) Click on Disable for Display Mixed Content instead of Prompt.
8) Click on OK twice.
9) Finally close and reopen the Internet Explorer
10) Try out the same web page that was displaying the warning message, the warning message should not appear any more.

The following video show how to do the following for easy reference.