500 Servlet Exception

WEB-INF/web.xml:25: java.lang.UnsupportedClassVersionError: Bad version
number in .class file


Resin-3.0.28 (built Mon, 18 May 2009 02:16:38 PDT)

Trying to install and run Openemm version 6.x gives an the above exception.

The line  25 on Web.xml looks like:

<filter-class>org.agnitas.web.filter.CharacterEncodingFilter</filter-class>

Solution

Verify the Java version that you are running with, most like you are running version 1.5 or less. You need to run Openemm with JDK version 1.6 or above.